分类 LINUX 下的文章

linux下的ssr折腾

我用deepin,尝试了好多种linux下的ssr客户端都不行,最后发现是很多linux用户都是这样,chrome的原因需要代理。
进入https://file.lucien.ink/SwitchyOmega下载下面两个文件
SwitchyOmega.crx
OmegaOptions.bak
打开chrome插件界面把SwitchyOmega.crx文件拖放到扩展程序页面,点击添加扩展程序进行安装。
打开SwitchyOmega的设置页面,跳过设置向导,点击导入/导出、从备份文件恢复、找到OmegaOptions.bak打开,恢复完成后点击应用选项。

这样就可以了。
参考:https://blog.csdn.net/xs18952904/article/details/80272579

另外最近新发现一个linux下的ssr gui客户端,尝试了下非常不错
项目地址:https://github.com/erguotou520/electron-ssr/releases
linux用户下载electron-ssr_0.2.3_amd64.deb 安装就行。
参考:https://blog.csdn.net/qq_36290650/article/details/80745378

pyinstaller 打包错误,OSError: Python library not found: libpython3.4mu.so.1.0, libpython3.4m.so.1.0, libpython3.4.so.1.0

错误提示如下:

24 INFO: PyInstaller: 3.2.1
25 INFO: Python: 3.4.1
25 INFO: Platform: Linux-2.6.32-220.el6.x86_64-x86_64-with-centos-6.2-Final
26 INFO: wrote /home/fmwei/src/lxa.spec
27 INFO: UPX is not available.
29 INFO: Extending PYTHONPATH with paths
['/home/fmwei/src', '/home/fmwei/src']
29 INFO: checking Analysis
29 INFO: Building Analysis because out00-Analysis.toc is non existent
29 INFO: Initializing module dependency graph...
30 INFO: Initializing module graph hooks...
31 INFO: Analyzing base_library.zip ...
1023 INFO: Processing pre-find module path hook   distutils
1814 INFO: running Analysis out00-Analysis.toc
1821 INFO: Caching module hooks...
1825 INFO: Analyzing /home/fmwei/src/lxa.py
1861 INFO: Loading module hooks...
1861 INFO: Loading module hook "hook-encodings.py"...
1906 INFO: Loading module hook "hook-pydoc.py"...
1906 INFO: Loading module hook "hook-xml.py"...
2048 INFO: Loading module hook "hook-distutils.py"...
2058 INFO: Looking for ctypes DLLs
2058 INFO: Analyzing run-time hooks ...
2066 INFO: Looking for dynamic libraries
2353 INFO: Looking for eggs
2353 INFO: Python library not in binary depedencies. Doing additional searching...
Traceback (most recent call last):
  File "/usr/local/python34/bin/pyinstaller", line 9, in <module>
    load_entry_point('PyInstaller==3.2.1', 'console_scripts', 'pyinstaller')()
  File "/usr/local/python34/lib/python3.4/site-packages/PyInstaller/__main__.py", line 90, in run
    run_build(pyi_config, spec_file, **vars(args))
  File "/usr/local/python34/lib/python3.4/site-packages/PyInstaller/__main__.py", line 46, in run_build
    PyInstaller.building.build_main.main(pyi_config, spec_file, **kwargs)
  File "/usr/local/python34/lib/python3.4/site-packages/PyInstaller/building/build_main.py", line 788, in main
    build(specfile, kw.get('distpath'), kw.get('workpath'), kw.get('clean_build'))
  File "/usr/local/python34/lib/python3.4/site-packages/PyInstaller/building/build_main.py", line 734, in build
    exec(text, spec_namespace)
  File "<string>", line 16, in <module>
  File "/usr/local/python34/lib/python3.4/site-packages/PyInstaller/building/build_main.py", line 212, in __init__
    self.__postinit__()
  File "/usr/local/python34/lib/python3.4/site-packages/PyInstaller/building/datastruct.py", line 161, in __postinit__
    self.assemble()
  File "/usr/local/python34/lib/python3.4/site-packages/PyInstaller/building/build_main.py", line 543, in assemble
    self._check_python_library(self.binaries)
  File "/usr/local/python34/lib/python3.4/site-packages/PyInstaller/building/build_main.py", line 626, in _check_python_library
    raise IOError(msg)
OSError: Python library not found: libpython3.4mu.so.1.0, libpython3.4m.so.1.0, libpython3.4.so.1.0
This would mean your Python installation doesn't come with proper library files.
This usually happens by missing development package, or unsuitable build parameters of Python installation.

* On Debian/Ubuntu, you would need to install Python development packages
  * apt-get install python3-dev
  * apt-get install python-dev
* If you're building Python by yourself, please rebuild your Python with `--enable-shared` (or, `--enable-framework` on Darwin)

- 阅读剩余部分 -

Ubuntu无法升级An upgrade from 'vivid' to 'xenial' is not supported with this tool.

我的版本是15.04,系统推送让升级到16.04。早想升级到16了正好今天不忙升级一下吧。还没开始就出错

20170105114027.jpg

然后百度An upgrade from 'vivid' to 'xenial' is not supported with this tool.相关内容,什么都没找到;又去google这才找到解决办法,先升级到到15.10然后再升级到16.04
链接地址:http://askubuntu.com/questions/804411/how-to-perform-do-release-upgrade-from-15-04-to-15-10-once-16-04-was-already-rel

终端do-release-upgrade -d,然后就慢慢等吧。记得在升级之前最好把源改为国内的吧

- 阅读剩余部分 -