2017年1月

Ubuntu无法升级An upgrade from 'vivid' to 'xenial' is not supported with this tool.

我的版本是15.04,系统推送让升级到16.04。早想升级到16了正好今天不忙升级一下吧。还没开始就出错

20170105114027.jpg

然后百度An upgrade from 'vivid' to 'xenial' is not supported with this tool.相关内容,什么都没找到;又去google这才找到解决办法,先升级到到15.10然后再升级到16.04
链接地址:http://askubuntu.com/questions/804411/how-to-perform-do-release-upgrade-from-15-04-to-15-10-once-16-04-was-already-rel

终端do-release-upgrade -d,然后就慢慢等吧。记得在升级之前最好把源改为国内的吧

- 阅读剩余部分 -

pip错误ImportError: cannot import name 'IncompleteRead'

在ubuntu上使用pip的过程中遇到了ImportError: cannot import name 'IncompleteRead'错误,如下:
filehelper_1483521441113_86.png

不论输入pip还是pip3或者pip3.4都一样,网上得知这是python pip的一个bug。
去网上找了很多方法,有人说用sudo easy_install -U pip,结果依然不行,下载不了,原因你的懂得;这时候就需要用国内源了。
豆瓣源:http://pypi.douban.com/simple/
终端:sudo easy_install -U -i http://pypi.douban.com/simple/ pip,如下:几秒钟就装好了

- 阅读剩余部分 -