如何在Mac OS X中调用ipython?

我安装了Scipy SuperPake,并有Pylab,Matplotlib,Scipy, Numpy显然运行良好. 但是我想使用matplotlib/pylab 互动. 这些说明暗示在Ipython中这样做. 但 在命令行上使用ipython会给我一个错误. 系统没有 知道命令. 显然,其中一个没有ipython可执行 bin目录. 我以为超级包会补充 自动,但我想没有. 谁能告诉我如何在MacOSX 10.4系统上运行Ipython? 谢谢你的帮助. (是的,我在Scipy电子邮件列表上问,但从未得到答案.) -Lou Pecora(我的观点是我自己的),将其删除给我.

# 回答1

您是否已使用 - 安装标记命令行选项安装它? 如果 您做到了,然后将有一个ipython脚本 $ install_scripts/bin目录. 如果您没有,那么我认为 默认位置是/usr/lib/python之类的.
# 回答2

Lou Pecora写道: 这只是一个猜测 - 但是您检查了您的 /library/frameworks/python.framework/versions/current/bin (从我的脑海中出来,但应该足够精确到达那里) ipython二进制的目录? 通常,那将是 任何编译/安装到框架构建的东西. 因此,要么将其添加到 您的路径,或创建链接到例如 /usr/local/bin diez
# 回答3

在文章<4p ************@uni-berlin.de>中, " Diez B. Roggisch"
# 回答4

在文章<11 ********************@e3g2000cwe.googlegroups中. com>, " jerry"
# 回答5

Lou Pecora写道:这只是一个猜测 - 但是您是否检查了/library/frameworks/python.framework/framework/versions/current/bin 只是检查了一下. 伊比恩(Ipython)没有什么. 您确定您是否在所有可能的位置进行检查 - 很可能是 例如 发货的Python2.3不在 /System/Library/.... 我自己无法检查一下,就像我在使用Linux一样. 它取决于您用来编译Scipy的哪个Python解释器. 可能是在/usr/local/bin下安装的 - 这可能是引起的 通过Scipy将其安装在那里. 我不太遵循这个最后的建议. 你能解释更多吗? _if_二进制安装在那里,您需要添加路径 路径环境,或创建指向路径中的位置的链接. 例如,我有 ln -s/library/frameworks/python.framework/versions/2. 4/bin/pydoc/usr/bin/pydoc2.4 在我的系统上,可以使用PYDOC2.4命令. 当然,您也可以创建一个别名. diez

标签: python

添加新评论